Moode Audio Player For Raspberry Pi

Discussion in 'All Things Digital' started by Thermionics, Mar 14, 2018.

  1. Thermionics

    Thermionics Post Whore In Training

    airdronian likes this.
  2. MikeyFresh

    MikeyFresh Moderator Staff Member

    I saw that and tried to place an immediate order, but nobody had any stock so I put it on preorder status with Adafruit.

    While the performance spec increase isn't really relevant to my endpoint/renderer side using Moode, this new 3 B+ board's increased performance might very well provide a performance lift on the unit I use as a server running the Linux variant of JRiver.

    I also decided against the Takechi enclosure from Japan, and instead ordered a Proto Armour case made in Buffalo, NY. I opted for the red anodized version, figured I'd splash a little color in and stop being so boring with everything silver or black.
    Last edited: Mar 20, 2018
  3. MikeyFresh

    MikeyFresh Moderator Staff Member

    Today I got confirmations from both Adafruit and PiShop that they are now shipping Pi3 B+ preorders, so I should have one if not two of these brand new boards next week.

    However my question posed on the JRiver support forum got a mixed response, one admin stating the new 3B+ board should be fully compatible with the current JRiver for Linux distro, and another admin questioning that and stating it really needs testing, but they weren't yet able to procure the board.

    So maybe I'm in a holding pattern with regard to using the 3B+ board for enhanced performance on my JRiver based server.

    On a positive note, Proto Armour quickly shipped their very cool aluminum enclosure, and I have already received it just 2 days later.
    Thermionics likes this.
  4. MikeyFresh

    MikeyFresh Moderator Staff Member

    The Proto Armour case for Raspberry Pi3 is a nicely machined piece. I like the raspberry red motif, this will make a cool enclosure for one of the new Pi3 B+ boards I have on the way, no tracking number yet on those boards, so for now I've got an empty case:


  5. airdronian

    airdronian Junior Member

    That looks really good ! One day I may look for a decent case for mine, but it will need to accommodate the Digi+ Pro HAT.

    On my list of things to do today is reimage Moode 4.0 on a Sandisk card as I think the Lexar I'm currently using is getting a bit dodgy. The in-place upgrade to 4.1 isn't too far off.
  6. MikeyFresh

    MikeyFresh Moderator Staff Member

    Thanks, yes this Proto Armour case is only useful for a Moode Player using USB output.

    It's tough to find a proper case that accommodates a specific HAT, in your instance I think your only good choice is the stainless steel one made for HiFiBerry by KKSB in Sweden. It might be your only choice for an off the shelf case custom fitted to the Digi+ HAT.

    I have their version for the HiFiBerry DAC+ Pro HAT, with cut-outs for a pair of RCAs, and it's quite nice for all of $28, far superior to plastic cases in terms of heat dissipation:


    On a separate note, PiShop shipped the new 3 B+ board today via Priority Mail. Coming from Newark, Delaware I should have it Tuesday or Wednesday.

    Any tips for the Moode 4.0 build? I have avoided it hoping there would at some point be a downloadable image, and I thought DietPi was working on offering that, but so far I don't see that happened. What did you do, just carefully follow Tim's build recipe or were someone else's tips/tricks also useful to the process?
    Last edited: Mar 19, 2018
  7. airdronian

    airdronian Junior Member

    Actually I'm in the middle of reinstalling 4.0 right now. Didn't want to image off a potentially failing microSD card.

    It's easy (I hope) the second time around. They are installing this way to appease licensing agreements. The plan is v4.1 will be an "in place" upgrade.

    Go to the Moode site and download the version of Stretch Lite they use. Must be that version. Image a disk with that. Boot up. I'm thinking you should go into settings and enable SSH at this time. (I did not and cannot view progress via ssh right now.) I am also using a wired network connection for simplicity.

    Here's the commands to enter:

    1. Download the Image Builder version 2.2

    cd /home/pi
    sudo wget -q -O /home/pi/
    sudo chmod +x /home/pi/

    2. Start the Image Builder

    sudo ./

    Once the process starts you will get a prompt asking you to ok the power off. Y to that and then remove your power connection to the Pi and plug it back in. It will continue install after boot. Then it's pretty well hands off for another 60 - 90 minutes depending on the vagaries of download speeds.

    They say you can monitor progress if you ssh into the Pi but I forgot to enable ssh (again) and so cannot watch it.
  8. airdronian

    airdronian Junior Member

    My first attempt seemed to work ok, but I get occasional drop outs which never happened with version 3.8.4 and I became suspicious of the microSD card. So I am doing an install on the card which ran fine with 3.8.4

    As far as linux-y things go, the above is pretty simple.
  9. airdronian

    airdronian Junior Member

    Simple huh.... my build today failed. :mad: Trying again...

    Success.... :dance
    Last edited: Mar 17, 2018
    MikeyFresh likes this.
  10. MikeyFresh

    MikeyFresh Moderator Staff Member

    Cool deal! I will embark on my maiden voyage manual build with 4.0 tomorrow, thanks for the pointers.
  11. airdronian

    airdronian Junior Member

    Memory is fading.. you can't go into "settings" on the Stretch Lite install as there is no GUI. Must have mixed up with Raspbian. I guess you would need to config the ssh server via command line. I went thru blind.

    The failed install seemed to be resulting from a few packages not being downloaded due to a file not found sort of error. Second time, worked just fine. And my suspicion of a dodgy microSD card seems to be correct. The Lexar had an issue or isn't good quality. Working just fine now from a Sandisk.

    I guess the only thing I would like better are the library listings, which are odd at times but I believe that's because the metadata of the files aren't in great shape. Want to look into a proper metadata editing app and see how that might help.
  12. MikeyFresh

    MikeyFresh Moderator Staff Member

    I've now had that same type thing happen 3 times in a row, seems the actual download of the image builder isn't really running, but nothing I've done wrong, the code is correct and I do have an internet connection/IP address on that Pi so I don't see what the problem is except I can't get their image builder script downloaded/in place, let alone actually run the executable.

    You managed this without using SSH from another computer? I see the instructions say to use SSH, but I see no reason why that code needs to be entered remotely via SSH (from elsewhere) when you can just issue the commands right there on the Pi you are doing the install on, or am I missing something?

    EDIT: After following the instructions for using SSH I got the freakin' Moode 4.0 image builder downloaded and running! I SSH'd into the Pi using my Mac and an Adafruit freeware program called PiFinder, and launched the image builder script.

    So now it's sit back and wait about 60 minutes and hope/pray nothing goes wrong from here as there is no more intervention I can take, either I'll have Moode 4.0 running on Raspbian Stretch Lite, or I won't.

    Incidentally, I'm not really sure what this whole SSH requirement is about, I don't see why all of the code can't be executed on the Pi itself, and in the instructions they seem to mention the benefit to using SSH is that you can then monitor the build progress remotely... but I:

    A) don't really care about progress so long as it concludes (I'm not going to sit there and stare at it)
    B) can already see that progress anyway on the Pi's connected HDMI display, lines of build code flying by, occasionally pausing, but who cares? I just want a finished and working Moode 4.0 when this is over.

    And then it will be shoot me in the head time if it turns out that I have to start all over from scratch again to accommodate something specific to those new Pi 3B+ boards I have on the way.
    Last edited: Mar 23, 2018
  13. airdronian

    airdronian Junior Member

    The ssh connection is to be able to monitor the progress of the mosbuild progress AFAIK. I've installed twice now without that. Blind, but it still worked. I was working directly on the Pi as you are.

    The way I see the commands is:
    1. navigate to /home/pi
    2. use wget to get the mosbuild script from the source at and download it to the /pi folder
    3. change the permissions to make it executable

    Starting the image builder is just running the executable which does all the work in updating the debian stretch-lite install with all the packages and configurations required. When you do the wget step and the chmod step, it should just return you pretty quick to your command prompt. No errors.

    When I referred to the errors downloading it was after the install had finished and I looked at some logs to see what went wrong.

    When you run sudo ./ it's going to do all the work. Be prepared to wait more than an hour. Maybe 90 mins. One way to see if it was successful is to type the IP of your Pi into a web browser and see if you get the web interface of Moode. You can't use Moode locally.

    Hope that helps. Let me know how it goes with your next attempt.
  14. MikeyFresh

    MikeyFresh Moderator Staff Member

    Thanks, that makes sense.

    I am about 39 minutes into the automated mosbuild script, seems to be all good, I'll know in another 30 minutes or so I guess, here is the progress view in SSH via PiFinder:

    Screen Shot 2018-03-18 at 6.17.58 PM.png

    Thrilling action, I'm on the edge of my seat.

    Attached Files:

    Last edited: Mar 18, 2018
  15. airdronian

    airdronian Junior Member

    Yup, just give it a while and try the IP in a web browser to test. Expect it to be longer than an hour.
  16. MikeyFresh

    MikeyFresh Moderator Staff Member

    Well 1 hour and 9 minutes later, and I think I'm done (it says END)?

    Screen Shot 2018-03-18 at 6.37.52 PM.png
    Last edited: Mar 19, 2018
  17. airdronian

    airdronian Junior Member

    Could be. I didn't see any output at all. Try the web interface.
  18. MikeyFresh

    MikeyFresh Moderator Staff Member


  19. airdronian

    airdronian Junior Member

    w00t !!

    You'll need to go thru config and get your settings the way you want them. Congrats !

    Once it's set up and working it's a good idea to image the disk to spare yourself a reinstall if that comes to pass. Don't know what you use for that, I've been using Apple Pi Baker.
    MikeyFresh likes this.
  20. airdronian

    airdronian Junior Member

    Oh, and version 4.1 will be out sooner than later. And it's promised to have an in-place upgrade, so no going thru this process again.

    I get Twitter notifications to learn about updates.

Share This Page